This document lists the supported sections and keys of the ini-style linphonerc configuration file.
This configuration can be served through https in order to remotely configure a linphone-sdk based application, see linphone_core_set_provisioning_uri().
The Flexisip Account Manager has built-in support for remote provisioning Linphone or linphone-sdk based client applications.
The sip section represents a general configuration for SIP signaling features.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| sip_port | integer | -2 - 65535 | -2=Don't Bind | linphone_core_set_transports() with linphone_transports_set_udp_port() |
Sets the UDP port in the LinphoneTransports object. |
| sip_tcp_port | integer | -2 - 65535 | -2=Don't Bind | linphone_core_set_transports() with linphone_transports_set_tcp_port() |
Sets the TCP port in the LinphoneTransports object. |
| sip_tls_port | integer | -2 - 65535 | -2=Don't Bind | linphone_core_set_transports() with linphone_transports_set_tls_port() |
Sets the TLS port in the LinphoneTransports object. |
| default_proxy | integer | -1 - INT_MAX | -1 | linphone_core_set_default_account() |
Sets the default account. |
| 100rel_support_level | integer | LinphoneSupportLevel | NoSupport | linphone_core_set_tag_100rel_support_level() |
Defines what level of support is provided to the 100rel attribute. |
| auto_send_ringing | integer | 0 or 1 | 1 | linphone_core_auto_send_ringing_enabled() |
Gets if the automatic sending of 180 Ringing is enabled or not. |
| automatic_http_proxy_detection | integer | 0 or 1 | 0 | linphone_core_automatic_http_proxy_detection_enabled() |
Returns whether automatic HTTP proxy detection is enabled. |
| capability_negotiations_reinvite | integer | 0 or 1 | 1 | linphone_core_capability_negotiation_reinvite_enabled() |
Checks if the capability negotiation (RFC5939) reINVITE is enabled or not. |
| cfg_lines_merge | integer | 0 or 1 | 1 | linphone_core_cfg_lines_merging_enabled() |
Checks if cfg lines are going to the merged if the capability negotiation (RFC5939) is supported or not. |
| client_cert_chain | string | A path | "" | linphone_core_set_tls_cert_path() |
Sets a TLS certificate path used for TLS authentication The path will be stored in the rc file and automatically restored on startup. |
| client_cert_key | string | A key | "" | linphone_core_set_tls_key_path() |
Sets a TLS key path used for TLS authentication The path will be stored in the rc file and automatically restored on startup. |
| dscp | integer | DSCP | 0 | linphone_core_set_sip_dscp() |
Sets the DSCP field for SIP signaling channel. |
| http_proxy_host | string | a hostname | "" | linphone_core_set_http_proxy_host() |
Sets HTTP proxy address to be used for signaling during next channel connection. |
| http_proxy_port | integer | 0 - 65535 | 3128 | linphone_core_set_http_proxy_port() |
Sets HTTP proxy port to be used for signaling. |
| in_call_timeout | integer | 0–86400 (s) | 0 | linphone_core_set_in_call_timeout() |
Sets the maximum duration of a call in seconds. |
| inc_timeout | integer | 0–300 (s) | Android and IOS: 45. Else: 30 | linphone_core_set_inc_timeout() |
Sets the incoming call timeout in seconds. |
| keepalive_period | integer | 0–60000 (ms) | 30000 | linphone_core_keep_alive_enabled() |
Is signaling keep alive enabled. |
| linphone_specs | string | "groupchat/1.1" | "" | linphone_core_set_linphone_specs_list() |
Sets the linphone specs list value telling what functionalities the linphone client supports. |
| media_encryption_mandatory | integer | 0 or 1 | 0 | linphone_core_is_media_encryption_mandatory() |
Checks if the configured media encryption is mandatory or not. |
| media_encryption | string | none, srtp, zrtp, dtls | none | linphone_core_set_media_encryption() |
Chooses the media encryption type to be used for RTP packets. |
| push_incoming_call_timeout | integer | seconds | 15 | linphone_core_set_push_incoming_call_timeout() |
Configures the minimum interval between a push notification and the corresponding incoming INVITE. |
| refresh_window | range | Range of seconds | 90-90 | linphone_core_set_refresh_window() |
Set the refresh window. |
| register_only_when_network_is_up | integer | 0 or 1 | 1 | linphone_core_set_register_only_when_network_is_up() |
Sets if accounts will wait for network to be connected before trying to REGISTER. |
| root_ca | string | a path | "" | linphone_core_set_root_ca() |
Sets the path to a file or folder containing trusted root CAs (PEM format) |
| sdp_200_ack | integer | 0 or 1 | 0 | linphone_core_sdp_200_ack_enabled() |
Media offer control param for SIP INVITE. |
| session_expires_enabled | integer | 0 or 1 | 0 | linphone_core_session_expires_enabled() |
Check if the Session Timers feature is enabled. |
| session_expires_min_value | integer | Positive number | 0 | linphone_core_set_session_expires_min_value() |
Sets the session expires minSE value, forced to a minimum of 90 by default. |
| session_expires_refresher_value | integer | LinphoneSessionExpiresRefresher | Unspecified | linphone_core_set_session_expires_refresher_value() |
Sets the session expires refresher value. |
| session_expires_value | integer | 0 or not lower than session_expires_min_value | 0 | linphone_core_set_session_expires_value() |
Sets the session expires value, 0 by default. |
| sip_update | integer | 0 or 1 | 1 | linphone_core_set_enable_sip_update() |
Enable or disable the UPDATE method support. |
| srtp_crypto_suites | string | List | "AEAD_AES_128_GCM, AES_CM_128_HMAC_SHA1_80, AEAD_AES_256_GCM, AES_256_CM_HMAC_SHA1_80" | linphone_core_set_srtp_crypto_suites() |
Sets the crypto suites available to the core. |
| support_capability_negotiations | integer | 0 or 1 | 0 | linphone_core_capability_negociation_enabled() |
Checks if the capability negotiation (RFC5939) is supported or not. |
| supported | string | Tags | "replaces, outbound, gruu, path" | linphone_core_set_supported_tag() |
Set the SIP supported tags. |
| tcap_line_merge | integer | 0 or 1 | 0 | linphone_core_tcap_lines_merging_enabled() |
Checks if tcap lines are going to the merged if the capability negotiation (RFC5939) is supported or not. |
| transport_timeout | integer | Milliseconds | 15000 | linphone_core_set_sip_transport_timeout() |
Sets the SIP transport timeout, which represents the maximum time permitted to establish a connection to a SIP server. |
| use_info | integer | 0 or 1 | 0 | linphone_core_set_use_info_for_dtmf() |
Sets whether SIP INFO method can be used to send digits. |
| use_ipv6 | integer | 0 or 1 | 0 | linphone_core_ipv6_enabled() |
Tells whether IPv6 is enabled or not. |
| use_rfc2833 | integer | 0 or 1 | 1 | linphone_core_set_use_rfc2833_for_dtmf() |
Sets whether RFC2833 or RFC4633 can be to be used to send digits. |
| user_agent | string | A user-agent | PACKAGE_NAME/LIBLINPHONE_VERSION | linphone_core_set_user_agent() |
Set the user agent string used in SIP messages. |
| verify_server_certs | integer | 0 or 1 | 1 | linphone_core_verify_server_certificates() |
Specify whether the tls server certificate must be verified when connecting to a SIP/TLS server. |
| verify_server_cn | integer | 0 or 1 | 1 | linphone_core_verify_server_cn() |
Specify whether the tls server certificate common name must be verified when connecting to a SIP/TLS server. |
| zero_rtp_port_for_stream_inactive | integer | 0 or 1 | 0 | linphone_core_zero_rtp_port_for_stream_inactive_enabled() |
Checks if RTP port is set to 0 when a stream is inactive. |
| Key | Value type | Possible values | Default value | Description |
|---|---|---|---|---|
| mwi_expires | integer | 0 - 9999999 | 86400 | The expiry time (in seconds) for message waiting indications (MWI) subscriptions |
| accounts_channel_isolation | integer | 0 or 1 | 0 | Always use one SIP connection per account. |
| account_strict_matching | integer | 0 or 1 | 0 | Only for tests. linphone_core_account_strict_matching_enabled() |
| answer_with_own_numbering | integer | 0 or 1 | 0 | Set answer with own numbering policy |
| auto_answer_replacing_calls | integer | 0 or 1 | 0 | Automatically answer replacing calls. Used for tests |
| auto_net_state_mon | integer | 0 or 1 | 1 | Enable automatic network state monitoring |
| bind_address | string | IP address | 0 | Set SIP listening address |
| bodyless_lists | string | SIP URI separated by ',' | "" | Bodyless friend list |
| cnx_ip_to_0000_if_sendonly_enabled | integer | 0 or 1 | 0 | Use legacy method for send-only streams (use of 0.0.0.0 connection address) |
| disable_media | integer | 0 or 1 | 0 | Disable media by ignoring SDP |
| force_name_addr | integer | 0 or 1 | 0 | Force all SIP headers enclosing addresses to use the name-addr ABNF serialization |
| handle_content_encoding | string | none, deflate, ... | deflate | Tells whether the given transport type is supported by the library..linphone_core_content_encoding_supported() |
| notify_all_ringings | integer | 0 or 1 | 0 | |
| only_one_codec | integer | 0 or 1 | 0 | Enforce one codec selection policy during SDP offer/answer |
| ping_pong_verification | integer | 0 or 1 | 1 | Enable check with Ping-Pong (RFC5626) |
| pong_timeout | integer | seconds | 10 | Pong Timeout. |
| prefer_ipv6 | integer | 0 or 1 | 1 | Set IPV6 preference for SIP connections. |
| reconnect_to_primary_asap | integer | 0 or 1 | 0 | Enable the reconnection to the primary server when it is up again asap. |
| refresher_retry_after | integer | Milliseconds | 60000 | After a REGISTER connection failure, define the default retry-after period, if not given by server. |
| save_auth_info | integer | 0 or 1 | 1 | if true, auth infos will be write in the config file when they are added to the list |
| set_p_asserted_identity_in_responses | integer | 0 or 1 | 0 | Include a P-Asserted-Identity (PAI) header in responses to incoming SIP calls. |
| sip_tls_well_known_port | integer | 0 - 65535 | 5061 | The well known TLS port |
| sip_well_known_port | integer | 0 - 65535 | 5060 | The well known TCP/UDP port |
| tcp_tls_keepalive | integer | milliseconds | 30000 | SIP keep-alive interval on TLS. |
| tls_certificate_subject_regexp | string | regex | "" | the purpose of this handling is to a peer certificate for which there is no single subject matching the regexp given in the "tls_certificate_subject_regexp" property |
| unreliable_connection_timeout | integer | seconds | 120 | Set the time interval in seconds after which a connection is considered to be unreliable because no data was received over it. belle_sip_stack_set_unreliable_connection_timeout(). |
| use_no_initial_route | integer | 0 or 1 | 0 | Use no initial route header |
| use_rport | integer | 0 or 1 | 1 | Use rport parameter in via |
| vfu_with_info | integer | 0 or 1 | 1 | Enable VFU request using SIP INFO |
The sound section represents the audio configurations.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| playback_gain_db | float | -30 to +30 (dB) | 0 | linphone_core_set_playback_gain_db() |
Allow to control play level before entering sound card: gain in db. |
| mic_gain_db | float | -30 to +30 (dB) | 0 | linphone_core_set_mic_gain_db() |
Allow to control microphone level: gain in db. |
| echocancellation | integer | 0 or 1 | 1 | linphone_core_enable_echo_cancellation() |
Enables or disables echo cancellation. |
| use_files | integer | 0 or 1 | 0 | linphone_core_set_use_files() |
Ask the core to stream audio from and to files, instead of using the soundcard. |
The video section represents the video configuration.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| capture | integer | 0 or 1 | 1 | linphone_core_enable_video_capture() |
Enable or disable video capture. |
| display | integer | 0 or 1 | 1 | linphone_core_enable_video_display() |
Enable or disable video display. |
| size | string | qcif, cif, vga, 720p | vga | linphone_core_set_preferred_video_definition_by_name() |
Sets the preferred video definition by its name. |
The net section represents the network configuration.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| adaptive_rate_control | integer | 0 or 1 | 1 | linphone_core_enable_adaptive_rate_control() |
Enable adaptive rate control. |
| adaptive_rate_algorithm | string | "advanced", "basic" | "advanced" | linphone_core_set_adaptive_rate_algorithm() |
Sets adaptive rate algorithm. |
| download_bw | integer | any positive integer or 0 | 0 | linphone_core_set_download_bandwidth() |
Sets maximum available download bandwidth This is IP bandwidth, in kbit/s. |
| upload_bw | integer | any positive integer or 0 | 0 | linphone_core_set_upload_bandwidth() |
Sets maximum available upload bandwidth This is IP bandwidth, in kbit/s. |
| mtu | integer | 576–1500 | 1300 | linphone_core_set_mtu() |
Sets the maximum transmission unit size in bytes. |
| dns_srv_enabled | integer | 0 or 1 | 1 | linphone_core_enable_dns_srv() |
Enable or disable DNS SRV resolution. |
| dns_search_enabled | integer | 0 or 1 | 1 | linphone_core_enable_dns_search() |
Enable or disable DNS search (use of local domain if the fully qualified name did return results). |
| push_notification | integer | 0 or 1 | 0 | linphone_core_enable_push_notification() |
Enables or disables push notifications on Android & iOS. |
| wifi_only | integer | 0 or 1 | 0 | linphone_core_enable_wifi_only() |
Turns Wifi only mode on or off. |
| friendlist_subscription_enabled | integer | 0 or 1 | 1 | linphone_core_enable_friend_list_subscription() |
Sets whether or not to start friend lists subscription when in foreground. |
| nat_policy_ref | string | a NAT policy section name | "" | linphone_core_set_nat_policy() |
Set the policy to use to pass through NATs/firewalls. |
| Key | Value type | Possible values | Default value | Description |
|---|---|---|---|---|
| download_ptime | integer | positive integer | -1 | Packetization time for download in milliseconds (deprecated in favor of [rtp] download_ptime) |
| enable_nat_helper | integer | 0 or 1 | 1 | Enable or disable the SIP provider NAT helper |
| nat_sdp_only | integer | 0 or 1 | 0 | Obsolete parameter to force NAT address only in SDP |
| activate_edge_workarounds | integer | 0 or 1 | 0 | Enable 2G/EDGE workarounds when STUN ping exceeds threshold |
| edge_ping_time | integer | positive integer | 500 | STUN ping time threshold in milliseconds to trigger EDGE workarounds |
| edge_bw | integer | positive integer | 20 | Bandwidth limit in kbit/s applied in EDGE low bandwidth mode |
| edge_ptime | integer | positive integer | 100 | Packetization time in milliseconds applied in EDGE low bandwidth mode |
| recreate_sockets_when_network_is_up | integer | 0 or 1 | 0 | Recreate media sockets when network connectivity is recovered |
| dtmf_delay_ms | integer | positive integer | 200 | Delay between DTMF tones in milliseconds for a DTMF sequence |
| android_ignore_network_background_restriction | integer | 0 or 1 | 0 | Ignore Android background network restrictions |
| allow_late_ice | integer | 0 or 1 | 0 | Allow late ICE negotiation after call establishment |
| ice_session_enable_message_integrity_check | integer | 0 or 1 | 1 | Enable message integrity checks on ICE STUN packets |
| dont_default_to_stun_candidates | integer | 0 or 1 | 0 | Do not default to STUN reflexive candidates in ICE session |
The rtp section represents the RTP configuration.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| audio_rtp_port | integer | 1024–65535 | -1 (random) | linphone_core_set_audio_port_range() |
Sets the UDP port range from which to randomly select the port used for audio streaming. |
| video_rtp_port | integer | 1024–65535 | -1 (random) | linphone_core_set_video_port_range() |
Sets the UDP port range from which to randomly select the port used for video streaming. |
| nortp_timeout | integer | 0–300 (s) | 30 | linphone_core_set_nortp_timeout() |
Sets the no-rtp timeout value in seconds. |
| rtp_no_xmit_on_audio_mute | integer | 0 or 1 | 0 | linphone_core_set_rtp_no_xmit_on_audio_mute() |
Enables or disables RTP transmission when audio is muted. |
| rtcp_mux | integer | 0 or 1 | 0 | linphone_core_enable_rtcp_mux() |
Enables or disables rtcp-mux. |
| accept_rtcp_mux | integer | 0 or 1 | 1 | linphone_core_enable_accept_rtcp_mux() |
Enables or disables the acceptance of rtcp-mux when proposed in an incoming offer. |
| Key | Value type | Possible values | Default value | Description |
|---|---|---|---|---|
| rtp_symmetric | integer | 0 or 1 | 0 | Enable symmetric RTP assumption |
| rtcp_enabled | integer | 0 or 1 | 1 | Enable RTCP |
| csrc_usage_allowed | integer | 0 or 1 | 0 | Allow CSRC usage in RTP streams generated by mixers, typically in conferences. |
The chat section represents the global chat configuration settings of a LinphoneCore. Table chat parameters lists all parameters one may find under section [chat] of a Linphone RC file.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| delete_contents | integer | 0 or 1 | 0 | linphone_core_enable_chat_message_files_deletion() |
Enable automatic deletion of files attached to LinphoneChatMessage . |
| ephemeral_message_policy | integer | LinphoneEphemeralChatMessagePolicy | LinphoneEphemeralChatMessagePolicyDisabled | linphone_core_set_ephemeral_chat_message_policy() |
Sets the policy for ephemeral chat messages. |
| message_automatic_resending_s | integer | any positive integer or 0 | 10 | linphone_core_set_message_automatic_resending_delay() |
It sets the duration of the timer to resend a message when the channel is broken (i.e. |
| delay_message_send_s | integer | any positive integer or 0 | 10 | linphone_core_set_message_sending_delay() |
Sets the maximum duration, in seconds, that a chatroom will wait for the NOTIFY carrying the full state of an encrypted chatroom before sending the chat message anyway. |
| delay_message_send_app_ext_s | integer | any positive integer or 0 | 3 | linphone_core_set_message_sending_delay_app_ext() |
It sets the duration of the timer to delay the sending of chat messages in flexisip based chatrooms after sending the SUBSCRIBE out. |
| sender_name_hidden_in_forward_message | integer | 0 or 1 | 0 | linphone_core_enable_sender_name_hidden_in_forward_message() |
Enables whether or not to hide sender name in forwarded message. |
| imdn_to_everybody_threshold | integer | any positive integer | 5 | linphone_core_set_imdn_to_everybody_threshold() |
Sets the threshold for sending IMDN to all participants in a group LinphoneChatRoom. |
| max_participants_per_chatroom | integer | any integer | -1 | linphone_core_set_max_participants_per_chatroom() |
It sets the maximum number of participants a LinphoneChatRoom object on a server can support. |
| chat_room_handling_set | integer | enumeration LinphoneChatRoomHandlingSet | LinphoneChatRoomHandlingSetAll | linphone_core_set_chat_rooms_handling_set() |
Set the category of chatrooms are handled by the core. |
| Key | Value type | Possible values | Default value | Description |
|---|---|---|---|---|
| max_delay_to_edit_retract_already_sent_message | integer | 0 - INT_MAX | 84600 | Maximum delay in seconds to edit or retract a sent message. |
The misc section represents unspecific options.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| max_calls | integer | 0 - INT_MAX | 10 | linphone_core_set_max_calls() |
Sets the maximum number of simultaneous calls Linphone core can manage at a time. |
| user_agent | string | RFC3261 compatible user-agent value | "" | linphone_core_set_user_agent() |
Set the user agent string used in SIP messages. |
| empty_chat_room_deletion | integer | 0 or 1 | 0 | linphone_core_enable_empty_chatrooms_deletion() |
Enable the deletion of empty chatrooms (i.e. |
The proxy_N sections represents SIP accounts.
Their name inherits from the legacy object name LinphoneProxyConfig in liblinphone, that is now superseeded by by the LinphoneAccount and LinphoneAccountParams object, but the linphonerc section name was left unchanged to preserve configuration file compatibility.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| reg_identity | string | SIP address | "" | linphone_account_params_set_identity_address() |
Sets the user identity as a SIP address. |
| reg_proxy | string | SIP address | "" | linphone_account_params_set_server_address() |
Sets the SIP proxy or registrar address. |
| reg_route | string | SIP address | "" | linphone_account_params_set_routes_addresses() |
Sets a list of SIP route. |
| reg_sendregister | boolean | 0 or 1 | 1 | linphone_account_params_enable_register() |
Indicates either or not, REGISTRATION must be issued for this LinphoneAccountParams. |
| reg_expires | integer | any strictly positive integer | 3600 | linphone_account_params_set_expires() |
Sets the registration expiration time in seconds. |
| realm | string | any string | "" | linphone_account_params_set_realm() |
Set the realm of the given account params. |
Their role is not to present a permanent list of contacts to the user, but rather return, per a search request, a list of contacts that match the request.
The search request is transmitted through the protocol (LDAP or CardDav), and executed on the server. The server's response is analysed and search results are represented as a list of LinphoneFriend objects.
LDAP connection configuration has it is own password key, and it is not relying at all on the LinphoneAuthInfo objects, unlike all other liblinphone initiated connections.
Table remote contact directory parameters lists all remote contact directory parameters one may find under section [remote_contact_directory_N] of a Linphone RC file.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| enabled | integer | 0 or 1 | 1 | linphone_remote_contact_directory_enable() |
Enable this remote contact directory, ie make it usable for searches with the LinphoneMagicSearch object. |
| type | string | carddav or ldap | "" | linphone_remote_contact_directory_get_type() |
Gets the type of remote contact directory (LDAP, CardDAV). |
| uri | string | a URI | "" | linphone_remote_contact_directory_set_server_url() |
Sets the server URL to use to reach the remote contact directory server. |
| min_characters | integer | any positive integer or 0 | 3 | linphone_remote_contact_directory_set_min_characters() |
Sets the minimum number of characters to have before sending the query to the server. |
| results_limit | integer | any positive integer or 0 | 0 | linphone_remote_contact_directory_set_limit() |
Sets the maximum number of results to fetch, 0 means no limit. |
| timeout | integer | any positive integer or 0 | 5 | linphone_remote_contact_directory_set_timeout() |
Sets the timeout (in seconds) after which the query is abandonned. |
| delay | integer | any positive integer or 0 | 500 | linphone_remote_contact_directory_set_delay() |
Sets the delay between each search in milliseconds. |
| Key | Value type | Possible values | Default value | Description |
|---|---|---|---|---|
| carddav_fields_for_user_input | string | "" | List of comma separated VCard fields to match with the user input | |
| carddav_fields_for_domain | string | "" | List of comma separated VCard fields to match for SIP domain | |
| carddav_use_exact_match_policy | integer | 0 or 1 | 0 | Whether the match must be exact or approximate (ignoring accents, case, ...) |
| ldap_bind_dn | string | "" | LDAP bind distinguished name | |
| ldap_auth_method | integer | 0: anonymous | 1 | LDAP authentication method |
| 1: simple | ||||
| ldap_base_object | string | "" | LDAP base object | |
| ldap_name_attribute | string | "sn" | LDAP attribute(s) to browse for contact names | |
| ldap_sip_attribute | string | "mobile,telephonenumber,homephone,sn" | LDAP attribute(s) to use to create SIP URIs associated with this remote contact directory | |
| ldap_sip_domain | string | "" | A SIP domain to filter results | |
| ldap_filter | string | "(sn=%s)" | A LDAP search filter |
The auth_info sections provide authentication information to use for SIP as well as http services (typically remote provisioning, cardDav requests). They need to be supplied in the form of a LinphoneAuthInfo object, whose configuration storage representation is of [auth_info_N] sections, numbered continuously from 0.
Table authentication information parameters lists all parameters one may find under section [auth_info_N] of a Linphone RC file.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| username | string | anything | "" | linphone_auth_info_set_username() |
Sets the username. |
| domain | string | anything | "" | linphone_auth_info_set_domain() |
Sets the domain for which this authentication is valid. |
| passwd | string | anything | "" | linphone_auth_info_set_password() |
Sets the password. |
| realm | string | anything | "" | linphone_auth_info_set_realm() |
Sets the realm. |
| ha1 | string | anything | "" | linphone_auth_info_set_ha1() |
Sets the ha1. |
| algorithm | string | MD5 | MD5 | linphone_auth_info_set_algorithm() |
Sets the algorithm to use. |
| authorization_server | string | any HTTP/HTTPS URI | "" | linphone_auth_info_set_authorization_server() |
Sets the authorization server URI. |
| token_endpoint | string | any HTTP/HTTPS URI | "" | linphone_auth_info_set_token_endpoint_uri() |
Sets the token endpoint HTTPS URI (OAUTH2). |
| client_id | string | anything | "" | linphone_auth_info_set_client_id() |
Sets the OAUTH2 client_id. |
| client_secret | string | anything | "" | linphone_auth_info_set_client_secret() |
Sets the OAUTH2 client_secret. |
The storage section represents the global storage configuration settings of a LinphoneCore. Table storage parameters lists all parameters one may find under section [storage] of a Linphone RC file.
| Key | Value type | Possible values | Default value | API | Description |
|---|---|---|---|---|---|
| update_db_at_initialisation | boolean | 0 or 1 | 1 | linphone_core_enable_update_db_at_startup() |
Enable or disable database initialization at start up If it is disabled, the database scheme will not be created during the SDK boot phase and the end user is responsible to ensure that it has been created beforehand. |